joomla_obnovlenie_8Как известно, совсем недавно вышла новая версия любимого веб-девелоперами инструмента под названием Joomla. Обновления принесли с собой много положительных и полезных моментов, которые станут незаменимыми во время работы любого веб-разработчика. Но теперь перед большинством веб-девелоперов стал довольно важный и серьезный вопрос: а как осуществить переход со старой версии на обновленную? Изначально существовал вопрос о том, или необходимо вообще переходить на новую версию. После предоставления компанией полного перечня изменений, которые имеются в новой версии, эти сомнения отпали. Довольно большое количество девелоперов просило о том, чтобы представители компании предоставили полную пошаговую инструкцию по переходу на новую версию инструмента. Компания услышала и создала такую инструкцию, которая станет незаменимой для всех веб-разработчиков.

На данный момент, процедура миграции со старой версии Joomla на новую является достаточно сложной и требует много личного времени. Тем не менее, представители компании обещают, что в дальнейшем, процедура миграции будет достаточно простой и будет занимать всего лишь несколько минут. На сегодняшний день существует только один мигратор, который помогает осуществить миграцию на новую версию Joomla. Данный мигратор не является официальным, но в процессах его разработки принимали участие люди, которые являются разработчиками ядра инструмента Joomla. Мигратор имеет название jUpgrade, а его основным разработчиком является Матиас Агирре.

Существует 2 основные особенности, которые делают версию 1.6 гораздо мощнее и эффективнее версии 1.5 – это вложенность категорий, а также ACL. Данные преимущества актуальны только для более опытных девелоперов, которые работают с более сложными и насыщенными проектами.

Перед началом осуществления перехода очень важно убедиться в том, что сервер отвечает всем заявленным требованиям, присутствие которых является обязательным для корректной работы Joomla версии 1.6. К таким требованиям следует отнести присутствие Apache v 2.x, MySQL v 5.0.4+, а также наличие PHP v 5.2.4+. необходимо сказать, что требования значительно увеличились по сравнению с требованиями версии 1.5.


Введите ваш EMail адрес:

Похожие материалы:

Пост просмотрен: 672 раз

Если вы заметили орфографическую ошибку в тексте, выделите ее мышью и нажмите Ctrl + Enter.

Что думаешь? Прокомментируй!: